在Ubuntu 18.04 LTS中安装MEAN.JS堆栈

  • 在Ubuntu 18.04 LTS中安装MEAN.JS堆栈已关闭评论
  • 22 views
  • A+
所属分类:存储应用

在Ubuntu 18.04 LTS中安装MEAN.JS堆栈

MEAN.JS是一个开源的全栈JavaScript解决方案,用于构建快速,强大的Web应用程序。MEAN.JS堆栈包括MongoDB(NoSQL数据库),ExpressJs(NodeJS服务器端应用程序Web框架),AngularJS(客户端Web应用程序框架)和Node.js(JavaScript运行时,作为Web服务器平台而流行) )。在本教程中,我们将讨论如何在Ubuntu中安装MEAN.JS堆栈。本指南在Ubuntu 18.04 LTS服务器上进行了测试。但是,它应该适用于其他Ubuntu版本和Ubuntu版本。

安装MongoDB

MongoDB是一个免费的,跨平台的,开源的,NoSQL面向文档的数据库。要在Ubuntu系统上安装MongoDB,请参阅以下指南:

安装Node.js.

NodeJS是一个开源,跨平台,轻量级的JavaScript运行时环境,可用于构建可伸缩的网络应用程序。

要在系统上安装NodeJS,请参阅以下指南:

在安装MongoDB和Node.js之后,我们需要为MEAN.js堆栈安装其他必需的组件,如YarnGruntGulp

安装Yarn包管理器

Yarn是MEAN.JS堆栈用于管理前端包的包管理器。

要安装Bower,请运行以下命令:

$ npm install -g yarn

安装Grunt Task Runner

Grunt Task Runner用于自动化开发过程。

要安装Grunt,请运行:

$ npm install -g grunt-cli

要验证是否已安装Yarn和Grunt,请运行:

$ npm list -g --depth=0
/home/sk/.nvm/versions/node/v11.11.0/lib
├── grunt-cli@1.3.2
├── npm@6.7.0
└── yarn@1.13.0

安装Gulp任务运行器(可选)

这是可选的。你可以使用Gulp而不是Grunt。要安装Gulp Task Runner,请运行以下命令:

$ npm install -g gulp

我们已经安装了所有必需的先决条件 现在,让我们部署MEAN.JS堆栈。

下载并安装MEAN.JS Stack

如果尚未安装Git,请安装它:

$ sudo apt-get install git

接下来,使用以下命令git克隆MEAN.JS存储库:

$ git clone https://github.com/meanjs/mean.git meanjs

结果如下:

Cloning into 'meanjs'...
remote: Counting objects: 8596, done.
remote: Compressing objects: 100% (12/12), done.
remote: Total 8596 (delta 3), reused 0 (delta 0), pack-reused 8584
Receiving objects: 100% (8596/8596), 2.62 MiB | 140.00 KiB/s, done.
Resolving deltas: 100% (4322/4322), done.
Checking connectivity... done.

上面的命令会将最新版本的MEAN.JS存储库克隆到当前工作目录中的meanjs文件夹。

进到meanjs文件夹:

$ cd meanjs/

运行以下命令以安装测试和运行我们的应用程序所需的Node.js依赖项:

$ npm install

这需要一些时间。请耐心等待。


故障排除:

当我在Ubuntu 18.04 LTS中运行上面的命令时,我收到以下错误:

Downloading binary from https://github.com/sass/node-sass/releases/download/v4.5.3/linux-x64-67_binding.node
Cannot download "https://github.com/sass/node-sass/releases/download/v4.5.3/linux-x64-67_binding.node":

HTTP error 404 Not Found

[....]

如果您遇到类似“node-sass and gulp-sass”这类常见错误,请执行以下操作:

首先使用以下命令卸载项目和全局gulp-sass模块:

$ npm uninstall gulp-sass
$ npm uninstall -g gulp-sass

接下来卸载全局node-sass模块:

$ npm uninstall -g node-sass

首先安装全局node-sass。然后在本地项目级别安装gulp-sass模块。

$ npm install -g node-sass
$ npm install gulp-sass

现在使用命令从项目文件夹再次尝试npm安装:

$ npm install

现在所有依赖项都将开始安装而没有任何问题。


安装所有依赖项后,运行以下命令以安装应用程序所需的所有前端模块:

$ yarn --allow-root --config.interactive=false install

或者,

$ yarn --allow-root install

如果安装成功,您将在最后看到以下消息。

[...]
> meanjs@0.6.0 snyk-protect /home/sk/meanjs
> snyk protect

Successfully applied Snyk patches

Done in 99.47s.

测试MEAN.JS

已安装MEAN.JS堆栈。我们现在可以使用命令启动示例应用程序:

$ npm start

几秒钟后,您将看到如下消息。这意味着MEAN.JS堆栈正在运行!

[...]
MEAN.JS - Development Environment

Environment: development
Server: http://0.0.0.0:3000
Database: mongodb://localhost/mean-dev
App version: 0.6.0
MEAN.JS version: 0.6.0

在Ubuntu 18.04 LTS中安装MEAN.JS堆栈

要验证,请打开浏览器并导航到http://localhost:3000或  http://IP-Address:3000 /。您应该看到如下所示的屏幕。

在Ubuntu 18.04 LTS中安装MEAN.JS堆栈平均堆栈测试页面

恭喜!MEAN.JS堆栈已准备好开始构建Web应用程序。

有关详细信息,我建议您参考  MEAN.JS堆栈官方文档


想在CentOS,RHEL,Scientific Linux中设置MEAN.JS堆栈吗?有关详细信息,请查看以下链接。


 

相关资源:

  • 安卓客户端下载
  • 微信扫一扫
  • weinxin
  • 微信公众号
  • 微信公众号扫一扫
  • weinxin
avatar